The vendor mistakenly disabled Wentworth’s organizational access to Brightly, believing we had not renewed our contract. The Facilities team contacted the vendor to clarify our ongoing use of the work order module, and Brightly restored Wentworth’s access. Once restored, Wentworth community members were again able to use Brightly to submit work orders to the Facilities department.
Posted Mar 31, 2025 - 16:18 EDT
Resolved
The vendor has restored system access. This issue has been fully resolved at this time.
Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Mar 31, 2025 - 16:12 EDT
Identified
Engineers have acknowledged a service interruption for Brightly.
We are currently working with the vendor to restore service and updates will be posted as they become available.
If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted Mar 31, 2025 - 14:35 EDT
Investigating
Brightly (work order system) is experiencing a major outage.
Updates will be posted as they become available.
If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.